UltraBac Software Forum

UltraBac Software Forum (http://forum.ultrabac.com/index.php)
-   Exchange Agent (http://forum.ultrabac.com/forumdisplay.php?f=6)
-   -   CRC Error (http://forum.ultrabac.com/showthread.php?t=287)

Realtime 04-07-2008 05:23 AM

CRC Error
 
When we try do do a restore of the public folder DB we get a CRC integrity error... does this mean the backup is useless?

Thanks

Derek Beaney 04-07-2008 10:57 AM

hi,

Crc errors can be tricky to diagnose as to what the cause is.

Here is a listing of the most common reasons:

1. Bad backup (run a manual verify on the backup)
2. Bad Memory (run memtest, www.memtest.org )
3. Bad Sector on hard drive (run chkdsk /r )
4. Bad network connection (do restore locally)

Can i have you post the restore log here? it may show us a different reason.

Thanks!

Realtime 04-08-2008 03:52 AM

I have done a verify on the backup and it passed ok.

I can't shut the machine down to do a memtest or chkdsk at the moment as there is live data on it. ( can you confirm you meant the UB server and not the Exchange server?)


Below is the log for the restore:

RESTORE LOG - BEI UltraBac UltraBac 7.1.4 - Build Date:Mar 12 2004
RESTORE started On: 07/04/2008 At: 15:25:34

Description: Full Exchange 2003 Backup
User: COMMISSION\Administrator
Agent: Exchange
Not Password Protected
Computer Name: SCCRCSRV1
Device: Tape0 (ARCHIVE Python 06408-***9100)
Volume Label: FULL SCCRC BACKUP
Starting Volume Number: 1

Error: Writting to file 'Public Folder Store' failed when agent wrote 218 instead of 65536 bytes of data.
File 'SCCRCMAIL (E2K)\First Storage Group\Public Folder Store' fails CRC integrity check


RESTORE SUMMARY:
Restore Complete.
Begin: 15:25:34 End: 15:26:22 (0 h 00 m 48 s) - ( 1.33 KB/Sec 0.08 MB/Min 4.69 MB/Hour)
Media Capacity: 19.135 GB
Media Remaining: 18.365 GB
2 file(s) completed/1 file(s) selected.
64.00 KB completed/46.02 MB selected.

END OF LOG


Many Thanks

Kenny

Derek Beaney 04-08-2008 02:21 PM

Hi,

Looking at the log file, i would have to say the issue is with the destination point (the exchange server). The next step would be to run check disk / memtest on the exchange server.

Realtime 04-09-2008 07:34 AM

Update:

Checked the disks and they are fine, however memtest has failed - Got some new RAM on order and will update you once I receive and install it.

Realtime 04-16-2008 06:14 AM

I have received and installed the new ram and it looks like it's faulty too or the mobo is dying.

However I was having a look through the event log on the Exchange server and found these to logs after attempting a restore

Event Type: Error
Event Source: M***changeIS
Event Category: Exchange Backup Restore
Event ID: 9635
Date: 16/04/2008
Time: 14:05:58
User: N/A
Computer: SCCRCSRV2
Description:
Failed to find a database to restore to from the Microsoft Active Directory.
Storage Group specified on the backup media is 8d3937f0-e669-416e-8eac-7907cab6a449.
Database specified on backup media is Public Folder Store, error is 0xc7fe1f42.

For more information, click http://www.microsoft.com/contentredirect.asp


And This one ...........

Event Type: Error
Event Source: ESE BACKUP
Event Category: Callback
Event ID: 904
Date: 16/04/2008
Time: 14:05:58
User: N/A
Computer: SCCRCSRV2
Description:
Information Store (2768) Callback function call ErrESECBRestoreGetDestination ended with error 0xC7FE1F42 Database not found.
.

For more information, click http://www.microsoft.com/contentredirect.asp.

The exchange server had exchange removed and reinstalled for this restore - am I missing step out? do I need to recreate the DB on the exchange server in a particular place with a particular name?

Realtime 04-22-2008 07:33 AM

The hardware looks OK now, the problem seems to be with the restore as per the event logs I posted.

Any ideas what this could be? Is it possible just to restore the actual database files rather than putting it back onto the server direct?

Kenny

Derek Beaney 04-22-2008 07:36 AM

Hi Kenny,

The errors that you are receving can be too complex to resolve over the fourm. Can i have you call our support team at 425-644-6000 so that we may resolve this issue for you?

Thanks!

Realtime 04-22-2008 08:45 AM

I won't have time to call in today, however here is some more info to ponder over.

http://support.microsoft.com/kb/841143

I had a look at the kb, and tried workaround 3 to no avail, so after this I tried to re-create the public store (Public Folder Store (SCCRCSRV2)) to see if this helped however it says that this object already exists. Any ideas on where this may exist so I can delete it?

Kenny

Realtime 04-28-2008 07:57 AM

Do you have a UK based helpdesk that I can call?


All times are GMT -8. The time now is 12:14 AM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2001-2019 UltraBac Software